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Presentations with Impress

by Andy Pepperdine

This paper covers the basics of using OpenOffice.org Impress to create a presentation from scratch. 
There are a lot features that will be touched on only briefly, and it will be clear from the menus 
what options can be experimented with.

How to get it

Impress is an integral part of any installation of OpenOffice.org, and is downloadable from 
http://www.openoffice.org/

Impress is like any other application, and after installation there should be an entry somewhere in a 
menu to start Impress.

Getting started

Depending on how you have started the full OpenOffice.org suite, a new presentation is created 
either from File → New → Presentation, or by starting Impress directly from the global application 
menu and not from a file browser.

It will first present you with a dialog to define a few simple things. Initially, you can just click Next 
twice and then Create and the simplest set up is ready to go.

Initially, the screen should show three panes. On the left the list of slides already created or are 
working on (the Slide pane), in the centre one with the workarea for the current slide, and the right a 
list of task types and options for them (the Task pane). If you need more space to work, then the left 
and right panes have a cross in the top right of each which will close them. To return them, use 
View → Slide Pane, or View → Task Pane.

Preparation

Some options about the way the workarea looks can be changed.

To make sure things look reasonably well lined up, and not crooked on the slide, you can ask for 
items to be aligned on a grid, and in that case you may wish to see the grid in outline. To make the 
grid visible, use View → Grid, where there are three options for how you want the grid to behave.

If you do not like the very faint grey default grid, then you can change the colour of it across the 
whole office suite from Tools → Options → OpenOffice.org → Appearance. Scroll down if 
necessary (it’s near the end) find the section for Drawing / Presentation where Grid will be defined, 
and you can change the colour of it. Light red is not bad for visibility.
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To change the resolution of the grid, go to Tools → Options → OpenOffice.org Impress → Grid, 
where you can set the major grid marks, and how many intermediate points between the major 
marks. Note that the number of points is not the same as the subdivisions. To show the halfway 
marks, the number of points is one, since there is one point visible between major marks, and hence 
the number of points should be set to one. The above screen shot shows a grid of light red, 2cm 
resolution with one intermediate point.

Defining an outline

You may wish to plan the talk first, before deciding what slides are required for each point you wish 
to make. In such a case, use the Outline tab above the work area in the centre pane. Then you can 
just go ahead and write all the points one after the other and prepare the textual parts of the 
presentation without pictures, transitions or any other distractions.

When typing the text, the Enter key starts a new point at the same level, and the default will be each 
line written is at the same level as the previous, and that starts by being each line on a different 
slide. But above the pane is a toolbar containing four fat arrows. Those which are orange in colour 
are active. The left pointing arrow will drop the current text line one level, the up and down arrows 
move the text up and down the list, and the right pointing arrow moves a line up a level in 
importance. These give you the ability to sketch out the presentation.
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When the draft is ready, switch back to the usual view with the Normal tab.

Putting in a background

Plain white may not be your thing, especially if you have some special logo you want to use. To set 
up a new template for each slide, select the Master Pages tab in the right pane, where a number of 
options are already available. There might be something suitable among them.

However, if you want to define your own, then start the editor for master pages from View → 
Master → Slide Master which will immediately switch to the slide master chosen. To prevent 
overwriting the masters already in use, hit the New Master button (on the left) in the Master View 
toolbar that will have appeared.

It will be a good idea now to rename the new master that you will be creating by right clicking on 
the template in the left pane, and selecting Rename Master when you can give it whatever name you 
wish.

To add a graphic to the background of the master, use Insert → Picture → From File. By default the 
new picture will be placed on the top layer, which is almost certainly not what you want as it will 
not be transparent. First, though, scale it by manipulating the cursor on the green markers; and then 
grab it and drag to its correct position.

Hint: Keeping the SHIFT key down while scaling retains the aspect ratio of the picture.

You will want the picture at the bottom of the layer stack so it shows through the text. So right click 
for the context menu and select Arrange → Send to Back. Right click → Area will give plenty of 
options to add backgrounds etc which may be appropriate, depending on the use you want for it.

This is still not right as it may be too strongly coloured, or too dark, and will disguise the important 
text to be written. A convenient way to tone down the colour is to place a white rectangle in front of 
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it, and allow it to be slightly transparent so only a little of the original colour shows. Along the 
bottom of the window are various drawing selection icons. Select the Rectangle and draw a 
rectangle of the appropriate size. You can leave a border if that is useful. Then right click → Area 
will enable you to change the colour of it to white, or whatever you want via the Colour tab. 
Moving on to the Transparency tab, set the Transparency option to 10% and see what it looks like 
for visibility. Adjust to taste.

There is one more thing that must be done with this rectangle, and that is to put it in front of the 
background picture, but behind the content of the slide. The easiest way I’ve found to do this is 
right click → Arrange → Send to Back, and then repeat with Bring Forward, thus putting it 
immediately in front of the previous lowest layer, the background picture.

To change the slide background colour, use right click → Slide → Page Set-up where a large 
number of options are defined for your use, including solid colours, gradations, hashing and various 
other effects. (When right clicking be careful not to pick up any of the objects already placed on the 
slide.) These are used as fillers between the objects as the lowest layer of all, so the transparency 
options of some of the overlays will make the background partially visible in different places. If the 
rectangle you chose did not fill the whole slide area, then this filler will appear as a border around 
it.

I chose the Marble under the Bitmaps, and now have something like this:

To change the header and footer for this slide master, select View → Header and Footer, where a 
dialog appears that is used to set up the various fields. On the slide master, these fields can also be 
moved to other parts of the slide. Finish with Apply to All, or Apply, whichever is appropriate.

When you have the master as you want it, close the master view with the Close Master icon in the 
floating Master View toolbar. The new master will appear under the Master Pages tab of the right 
pane (the Tasks pane). Clicking on it will set the current slide to use it; right clicking will give you 
the option of applying it to all the slides.
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Putting stuff onto a slide

After fiddling with the master slides, make sure that the Layout tab is visible in the right pane. 
These are the standard layouts for different types of slide, but it is easy to change them in various 
ways to whatever you want. They form a good starting point for each slide and can be selected for 
each slide separately.

The commonest things will be to get the bullet points in order, and the selection of the layout will 
position the bullets for that layout, leaving space for other things. But I will demonstrate just the 
simple layout and adjust it to suit the exact position I want.

By selecting the area containing the bullets, it can be re-sized like any other area by dragging the 
marks on its boundary.

For one of the slides, I chose the Title and 2 Text Blocks by clicking on it.

Adding pictures

The simplest way is when the picture is already in a file of its own elsewhere. To add such a picture, 
use Insert → Picture → From File and it will appear original size and can then be sized and moved 
to its appropriate position.

It is also possible to crop pictures. After a picture has been placed, use the Crop icon in the picture 
toolbar (looks like a pair of scissors). Note that this does NOT crop the original, so it can be re-
cropped to a larger size later if necessary. The cropping affects the appearance only. An example is 
the right hand picture being adjusted here, where you see the cropping markers are blue-grey:

Adding a chart from a Calc spreadsheet

If you have a chart developed in another application, it may be possible to cut and paste, depending 
on the application. This example is from Calc, another part of the OpenOffice suite.
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By opening the spreadsheet in Calc, selecting the chart, and copying it (Ctl-C, or Edit → Copy), we 
can then revert to Impress and paste into the appropriate slide (Ctl-V, or Edit → Paste). The new 
object can then be resized as required, although I’ve noticed a few rough edges in the 
implementation of this feature. An example is shown below, using the Title & Object layout:

Some words about how this was created. After the paste, the sizes of the legend and the chart were 
not suitable and had to be adjusted. This can be achieved by double clicking on the chart and it will 
enter the OLE editor to allow the various components to be modified. In particular, by leaving the 
cursor on the legend text and then right clicking, the menu gives options for changing the fonts and 
other attributes of the legend, and re-positioning if necessary. The transparency of the object can be 
changed in a similar manner, and this is how some of the background was made to be visible 
through the object. Experiment to see what looks right in any given case.

Making transitions between slides more interesting

(Or annoying depending on whether you are the presenter or audience).

By default, slides appear on a mouse click complete, without any special effects. The whole slide 
could be treated as a unit and brought into focus, zoomed in, faded in, or lots of other possibilities 
by using the Slide Transition tab in the right pane, where lots of options are available. It is largely 
obvious how to set these up, and previews are available to see what they look like.

You can also specify a sound to accompany it from the Sound drop-down. At the bottom of the list 
is an option to use your own sound file, which I prefer as the built-in ones are not to my liking.

Animations

As well as fancy transitions between slides, there are also many alternatives as to how elements on a 
slide are brought into view. For example, each line of text can be brought in with a separate click on 
the mouse, possibly with highlighting of the text of the point in question.
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To access these, use the Custom Animation in the Tasks pane.

By default all the elements on a slide come in with the transition. To make one come in later, select 
the element by clicking on it in the slide pane, and then hit Add in the Custom Animation tab area. 
This brings up a list of types of entry, exit, motions, and emphasis types, all of which can be 
selected at this point and then hit Apply. The element will then will appear in a list in the Animation 
tab. To change the details of the animation, hit the button to the right of Property and labelled “...”. 
You now have the opportunity to delay the appearance of the item. A useful feature if setting up an 
automatically running slide show. To bring in several elements with the same mouse click, perhaps 
with differing delays for each element, then the Start drop down gives options to start the effect 
with the previous mouse click. if you choose this, you will see a change to the leading icon for that 
element in the list of elements for which effects are defined, indicating whether a mouse click is 
needed for it to take start.

An example of the final result is:

Adding interaction to an element

Sometimes, you may want some form of interaction to take place when a particular element of a 
slide is clicked on. I’ll take the example of a sound file to play.

First add a suitable element, like an icon, or clipart that can act as the element with which to interact 
to the slide you are interested in. This will be trigger element to be clicked on. I chose the clipart 
picture of a treble clef to represent the sound file. Then right click on the element and select 
Interaction from the context menu. This gives a drop down list of options. One of the options is to 
play sound, but you can in fact run any program you choose by selecting the appropriate item in the 
list. Now you can browse for the file you want. When you have done that, just clicking on the 
element will play the sound file, which means that to select the element, a right click is necessary.
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A word about moving to another file system

One might imagine that a presentation from Impress could be moved onto a memory stick (or CD) 
and played from there. This is currently not the case if there are any external files, like sound or 
video interactions, or sound transitions, which lie on another device or if they are accessed 
through symbolic links (Unix-like systems only). The reason is that such files are not incorporated 
into the presentation, but kept separate.

It should work if all files associated with a presentation are placed in the same folder and always 
kept together. This means that when any of the gallery items are selected for incorporation, they 
should be copied into the same folder first, and then included as user supplied files.

Further information

Many templates for slides can be found at http://smalldataproblem.org/ooextras/

There is more about some aspects of Impress at http://www.zisman.ca/Impress/index.html

and at http://documentation.openoffice.org/tutorials/cospa/Cospa_Impress_Tutorial.pdf
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