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The nurture and care of Thunderbirds

by Andy Pepperdine

This paper is about some of the functions of the Thunderbird e-mail client program. It will attempt 
to describe what Accounts and Identities are; one way to use the folders it keeps; how to use filters 
to separate subjects; and what tags could be used for. There is a lot more to this free program, but 
that will be ample to get you used to some useful features.

How to get it

If you do not have Thunderbird, just put “thunderbird download” (without quotes) into your 
favourite search engine and you’ll quickly get to http://en-gb.www.mozillamessaging.com/en-
GB/thunderbird/ (if you’re in the UK) where you will be able to get the latest one, which is version 
3.

This paper is based on version 2 as installed from the Ubuntu 9.10 packages. The new features 
appear to be largely improvements to the interface, but the new wizards may make it easier for 
newcomers to get started. If anyone has tried TB 3, please let us know what you think.

Accounts

For each different e-mail address, you will be accessing a server to download the mail messages; for 
each of these addresses, you will create a single account under Thunderbird.

The dialog is reached from Edit → Account Settings... To add an account, hit the Add Account 
button at the lower left. This paper deals only with e-mail accounts, so ensure the Email account is 
marked and then hit Next.

More details of names (which you supply) and the server (which your e-mail provider will give 
you) will be needed. All of this information (except for the POP / IMAP decision) can be changed 
later, and indeed some extra settings can be changed only later; consequently this paper will now 
look only at the dialog for managing account details after the accounts have been initialised.

It is important to recognise that sending a message is a very different action from receiving one. 
Some ISP’s will insist on using their outgoing servers for e-mail from your own accounts with the 
ISP. Others are more free and you can use their servers to send e-mail from other accounts. You may 
also have access to a different outgoing server that you can use and is not associated with your ISP 
at all.

Keeping your security data safe

Thunderbird keeps log-in details and passwords in order that it can log in to your e-mail servers to 
retrieve the messages. To keep these safe, and from prying eyes, you can save them all behind a 
single password, which also has the advantage of reducing the number of items you have to 
remember.

From the menu Edit → Preferences you are taken to the dialog for settings that control 
Thunderbird’s behaviour overall as opposed to for each individual account. In this dialog, select the 
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Privacy icon along the top, and then the Passwords tab. Here you can set and change the master 
password to safeguard all the others.

You will have to enter it once every session to give Thunderbird access to all the other passwords to 
fetch your messages.

Account settings

Details about your accounts can be examined from the Edit → Account details... dialog. On the left 
hand side, you will see all your receiving accounts with various options available on each. The 
default account will be shown in bold at the head of the list; and at the bottom, some information 
about the Local folders, where you can keep all your messages; finally details about the servers you 
can use to send e-mails. It is worthwhile setting up the outgoing servers first as each account will 
need to say which outgoing one to use when writing messages.

Outgoing servers

The owner of the server will give you information about how to access the server to send e-mail. 
They are all sensitive to misuse of their facilities and will require you to “log-in” in some way to 
their server before sending any e-mail. For example, ISP’s may insist on you being connected via 
their line before access to the outgoing server will be allowed. Google will have you log-in using 
your Gmail address and password before allowing sending a message, and in addition they use a 
non-standard port number. Thunderbird will handle this automatically once the details about the 
servers has been given.

Each server will need a separate entry in the list of outgoing servers. Selecting the Outgoing server 
(SMTP) entry in the left pane shows the list of servers you have access to.
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Some servers require you to set up secure encrypted access, whereas others will manage with 
simpler methods.

Expanding any of the accounts in the left pane will show a number of headings. Selecting an 
account shows a dialog for that account. The outgoing server is set here. You must ensure that you 
are using an appropriate one for each account to ensure that new messages can be sent.
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Identities

Each account can have multiple identities. Clicking on the Managing identities... button will open a 
window that will enable you to create and edit identities.

Clicking on the Edit... button will show what is set already, and the Add... button takes you to the 
same dialog, where all the fields are blank – the only thing set is the outgoing server.

Identities can be used to separate cryptographically signed from unsigned e-mails you send. They 
can also be used to set an alternative reply address by giving the e-mail address as one in some 
organisation that forwards it to you at the current account address.

But probably the most common distinction between them is the signature text that is added 
automatically to the end of each e-mail sent. This can be used to give as much or as little extra 
information relevant to the identity as is required. For example, if you have a number of different 
rôles, then you may need to point to different websites, or job descriptions, so that the recipient 
knows who they are dealing with. It’s like using headed notepaper when writing a letter.

For example, I am the secretary of the maintenance company for the block where I live, and so if I 
send mail out in my official capacity as secretary, then I can append the appropriate signature text.

Another example, I have an account at OpenOffice.org under the login name of andypep. This 
account is set up to forward any mail it receives to my personal account at pepsplace.org.uk. 
Consequently I can create an identity for the OpenOffice mailing address which is part of the 
pepsplace Thunderbird account by hitting Add... in the screen shown above.

The resulting dialog allows you to set all the usual values in the four tabs shown in the next picture. 
It is convenient to add text to your name so that you can easily identify this identity, and it is 
obvious what it is associated with.
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You do not need to set the Reply-to address unless you want replies elsewhere. The other fields and 
tabs are copied from the account settings.

In addition, when setting up an account or identity, you can say where you want copies of mail that 
you have sent to be saved. Look under the Copies & Folders tab where you can tick the “Place a 
copy in:” box and then select the folder where they are to be saved. By default they are all saved in 
the Sent folder under Local Folders, but if you want to keep your identities separated, then you can 
save them under the Sent folder for the account.

If you are keeping work separated into clear categories, then you can save replies to messages in the 
same folder as the message being replied to. If you have filtered messages according to the task (see 
later), then you can keep the full conversation in the one place without having to move messages 
around much. The next picture has that box ticked.
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Important: You may find that you have to change the SMTP server listed because messages sent 
from this identity will appear to come from a different user and the server may refuse to forward 
them. It depends on the methods of authentication the server uses. If you keep the same e-mail 
address for all identities within a single account, then this will not be a problem.

Sending mail

When composing a message, the window shows a drop-down list against the e-mail address you are 
sending from.

The list lets you select the identity you want to send the mail from. Each account has a default 
identity which will be chosen when writing from that account (see Folders later). Switching 
identities will automatically change the attributes you have set for composing, so that some can 
have signatures, and others not; some may be cryptographically signed, others not, etc.
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Identities are not as flexible as I would like. For example, there is no way to associate a language 
with an identity to give spelling checks from the appropriate dictionary; you have to use the drop 
down list from the Spell icon on the Compose window. Thunderbird seems to pick up dictionaries 
that have been installed from the package manager in Ubuntu. The default language can be changed 
under Edit → Preferences → Compose → Spelling. If you do change the language, then it stays 
changed until it’s changed again – it does not revert after a single message has been sent.

Folders

In Thunderbird, a folder holds messages. Some folders are pre-determined, and others you can 
create for your own purposes. They are a good way to keep your correspondence organised.

In the left hand pane of the Thunderbird window, there is a list of folders in a hierarchy. New 
folders can be created by right clicking on a folder and selecting New Folder… when you will then 
be given a chance to give it a name. The folder will appear in the hierarchy below the one on which 
you right clicked.

Clicking on a folder name will display the messages that it contains in the upper right pane. 
Messages can be moved from the one being displayed to another by selecting the message header 
and dragging it to the folder where you want to put it.

You can say where new messages for a particular account are placed by Edit → Account settings... 
and then selecting Server Settings. At the bottom of the dialog window, there is a box labelled Local 
directory with a browse button to find the relevant location. I think this defaults so that each account 
has its own Inbox.

In the left hand pane of folders, when a message arrives, the folder it is placed in is made bold to 
show that messages are there. If the folder is clearly visible, then it will also show the number of 
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unread messages.

At the top on the right of the pane of folders, there are two small arrow-like symbols. Clicking on 
the right hand one of the two will remove all folders from view except those which contain unread 
messages. This is useful if you have lots of folders and need to find all the new messages easily. 
Clicking on the left one restores the hierarchical view of all folders.

Filters

The normal case is for Thunderbird to place new messages in an Inbox folder according to your 
settings when you created the account. Filters are instructions to Thunderbird to find messages that 
have certain characteristics, which you specify, and then do something else with them. Normally 
they apply to new messages immediately they have been placed in the Inbox. But there are a 
number of options you can set for when and how they operate.

Suppose you are a recipient of regular e-mails because you are on a list for them. Typically, these 
will all have an identifiable character string in the subject line of each message. For example, the 
BBC daily e-mails always have for their subject: “Your daily e-mail from the BBC”. You can use 
filters to place all these e-mails in their own folder for you to read when you want to, instead of 
them clogging up your Inbox.

Filters are edited through Tools → Message Filters... when a dialog appears allowing you to edit 
your filters and to add more.

The drop-down list at the top of the window lists the account you want the filters to apply to. When 
you’ve selected the correct account, hit the New... button to add a new filter. It will come up with 
text to be replaced in the Filter Name field. Put an easily recognisable name in there so that when 
you come to edit later you know which filter is which from their names.
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The drop down on the left of the upper pane contains a number of possible fields that can be tested 
for. In this case, Subject is right. In the middle drop down list you can test for various things, but 
again “contains” is right as we are going to look for the contents of the Subject line of the message 
to have. In this case, I’ve just put BBC as it does contain that string.

If that is not a sufficient test, then you can add a further test by hitting the button labelled “+” and 
adding the test as in the next picture, but remember to change the “Match” choice correctly above 
the upper pane. We want to “Match all of the following”.

In the lower pane, you select the action (Move the message in our case), and also can select the 
folder to put it into from the right drop down list of folders.

Thunderbird-basics.odt edited: 2010-03-23 Page 9 / 14



2010-03-25 Thunderbird U3A in Bath

Then hit OK. The new filter will appear at the top of the list of filters. By selecting the filter, it can 
be moved to another position if you wish. You can also run it against the Inbox by selecting it and 
hitting Run Now.

When you do this, and the mail has not been read, Thunderbird will highlight the folders containing 
unread messages in bold in the folder list in the left hand pane of the main window. If the hierarchy 
is hidden, then the upper level will be made bold to show there are messages in the subfolders 
somewhere.

Tags

Tags are used to identify messages for special treatment by you. There is at the moment no easy 
way to filter on tags after they are set, although if you are downloading all your messages to your 
local machine, then there is an ungainly way round it. But if you are using IMAP and leaving them 
on the server, then you cannot do this. But see Message Source later in this document, and the 
further reading list.

To set a tag on a message, use either the icon Tag with its drop-down list, or Message → Tag, and 
select one of the 5 pre-defined ones, or New Tag... and make you own, giving it a colour with the 
small rectangle on the right of the name box.

Types of messages

Sometimes, someone may refer to encodings and html and text and such like. What are these? And 
why might they be important?

Html or Text?

You may have heard of “html” messages, or “text” messages, and wondered what they were and 
why it mattered. Well, at the beginning of sending e-mail, there was only text; html was not even an 
idea in anyone’s mind. But once html was invented, then people wanted to send messages that were 
more jazzed up than boring old type. But there was a problem. Not all e-mail clients could 
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understand html and so could not read the new formats well. Even now, there are some people who 
use, for one reason or another, remote connections that simply do not have the features necessary to 
display them – think of a command line interface, for example. Others will assume that anyone 
sending out messages in html format must be trying to sell something and will filter them out 
straight into the waste basket. If you do not know what your recipient has, and it is important that 
they can read and understand what you write, then there is no substitute for using text messages and 
not html. The settings for this can be found under the Composition and Addressing of the Account 
Settings window. Tick the first box if you want to use HTML messages. There is a similar tab for 
each identity as well.

What is an encoding?

You may also have seen messages that did not look right. What should have been a Euro symbol 
was instead something else. Or some foreign language characters were not displayed correctly 
making them difficult to interpret. The exact bit pattern for each character in a message is known as 
the encoding used for the message. There is a standard defined by ISO for a representation called 
Unicode, or ISO 10646, which currently needs a maximum of 21 bits per character. This can be 
reduced to a portable form (8 bits per character) by an encoding known as UTF-8. It is easily the 
most flexible and complete method to use when sending messages containing non-English letters 
and symbols. It is implemented almost everywhere, and increasingly replacing the older methods.

However, Windows has traditionally used its own methods of encoding languages which is more 
restrictive, but which will nevertheless often be encountered. To make matters worse, when using 
the Windows encodings, the messages occasionally do not say what encoding they are using. This 
makes receiving them problematic if you do not know which is in use and have to try several 
alternatives until one makes sense.

Message source

How do I tell what sort of message it is? The answer is to look in the full text of the message, not 
what has been extracted to allow you to read it. The way to do that is to select the message , and 
then either hit (CTRL+U) together, or go to View → Message Source, when an edit box will come 
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up showing the exact content of the message. In the example below, the message contained the 
characters ô and  ï, neither of which are in the basic character set. When it was sent Thunderbird 
marked it as to be encoded in UTF-8.

The first line of every message, by Internet convention, starts with the 5 characters “From ”. The 
next lines essentially define the characteristics of the message and always have the format of a 
keyword followed by a colon and then values associated with that keyword. The one we are 
interested in here is the line starting “Content-Type:” and you will notice it contains the value 
“charset=UTF-8” which tells Thunderbird how to interpret the text of the message. The first line 
that is not of the header type indicates the start of the body of the message.

To see what the defaults are for both outgoing messages, and undefined incoming messages for the 
various languages supported, go to Edit → Preferences, select the Display icon, and the Formatting 
tab. Then hit the Fonts... button. A window will come up showing you more options than you really 
want to know about.

Keywords and filters

It is these keywords that can be searched for in filters. So when you want to filter on special types 
of messages not covered by the standard ones, then you can look at the source and pick out the 
keyword you need and customise a filter for it. For example, if you want to filter on the tags you 
have set then search for the tag “X-Mozilla-Keys” to contain the name of the tag you have defined. 
Note: The first 5 tags are pre-defined and are labelled specially by Thunderbird $label1 to $label5 in 
the header of a message. Those you define appear with the string you gave to the tag. The message 
above had been given the pre-defined tag “Later”, and the customised tag “demo”.

Thunderbird-basics.odt edited: 2010-03-23 Page 12 / 14



2010-03-25 Thunderbird U3A in Bath

Views

In the Windows world, Outlook Express has some security deficiencies that mean it is safest not 
have the preview pane visible. If you want to hide the equivalent pane, (for example, if you 
typically have very large inboxes that you wish to see fully laid out) then use View → Layout → 
Message Pane, or you can toggle between it hidden and not using the F8 function key.

It is not so important in Thunderbird to do this as by default it does not expand html unless asked to 
do so. In the menu View → Message Body As you will find three alternatives given for how html 
messages should be displayed. Each of these interprets a different amount, but they will, by default, 
all only show what is local to the message. Pictures fetched from external sites will normally not be 
shown as this is a potential security hole. Instead you will be shown along the top of the message a 
yellow panel giving the option to fetch them if you feel it is safe to do so.

Thunderbird also has three standard layouts for the usual panes. These are called Classic, Wide and 
Vertical all found under the View → Layout menu. Classic is the default, but it is easy to try the 
others to see whether they appeal.

Extensions

There are a number of useful extensions available for Thunderbird. To get them, use Tools → Add-
ons. Here are the ones that I have installed:

When you select one, it shows its status, as in the British English Dictionary above.

Enigmail is useful for handling encryption and signing of messages.

Lookout is invaluable if you ever receive a packed message from someone using Microsoft Outlook 
(not Outlook Express). Outlook is used in companies more and when forwarding other messages, 
for example, can pack their contacts up in a Winmail.dat attachment. Without this add-on you will 
have trouble extracting the parts of the message and reading them; but with it, it happens 
automatically.

To see what else you can get, click on the Get Extensions hyperlink – when I went there, in the six 
listed categories there were nearly 1300 in total.
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Further information

Filters are described at http://kb.mozillazine.org/Filters_%28Thunderbird%29

For the pedant, Unicode and ISO 10646 are not identical legally. The gory details are at 
http://unicode.org/faq/unicode_iso.html.
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