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Discussion comments by Andy Pepperdine
This document will cover a simple applications for merging information into labels for printing, and
use of LibreOffice for simple modifications of images for use elsewhere.

A simple labels tool
Here we describe the Linux program gLabels which is a simple way to generate a set of labels, 
allowing merging from a spreadsheet as appropriate. It can also be used to create business cards and
has the ability to insert and move around simple objects.

The easiest way to present the variable data (the addresses) to this application is the create a .csv 
file. To do that from a Calc spreadsheet is to select the sheet that contains the addresses and then 
File → Save As, select .csv from the Format dropdown list, and then save it. Refuse the request to 
save as .ods. However, this means that the format is changed and Calc will think it is operating on 
a .csv file instead of your spreadsheet as before.

It is best to perform these operation in this order: First save normally as a .ods file; then save as 
the .csv file; close the fiielyou are editing; finally re-open the .ods file to continue working on it. 
This is awkward, but Calc does not allow you to Export to a .csv file unfortunately.

gLabels
First, get the program from your package manager. It is quite small and installs quickly, and will 
appear under the Office menu item for Ubuntu-based systems.

Getting started
It behaves much like any graphical editor, so starting it up gives an empty canvas. The File menu 
allows an old one to be opened, or you can start a new one.

Starting a new file from File → New, will present you initially with a dialog to establish what labels
you will be printing on. Under the Search all tab you can select from any common manufacturer, 
selecting one or scanning all of them, then click on the one you want, and hit Next..

You are next asked to select which orientation you want to use, and the Next button takes you on to 
confirm your choices. After hitting Apply, you will be shown the outline of one label, and can 
populate it with the simple editing tools, which always start by creating the object, which is then 
filled in with the item(s) you want.

Editing text
To put text on the label, hit the T icon or find it in the menus (Object → Create → Text), and then 
click somewhere in the canvas. A box will appear. Text is added by typing in the pane on the right 
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that will also appear. You can resize the frame at will, and drag it to anywhere you want it via the 
usual click and hold while moving the mouse.

Text is added and edited in the right-hand pane. Fonts can be selected from the drop down and size 
options at the bottom of the window, and other features, like bold, italic, and simple formatting are 
available from other obvious icons along the bottom.

This will add any fixed text in all of the labels to be printed. Multiple text boxes can be created, and
each can have their own fonts and colours.

Merging mail addresses
To put different text on each label, then it has the ability to read from .csv files to pick up the 
relevant text for each label. To create a suitable file from Calc spreadsheet, see above in this 
document.

To do so, hit the Merge Properties icon, or use Objects → Merge Properties, to get a dialog to 
define where to get the information.

Using the dropdown list under Format gives you various formats for the list. If your information hs
names of fields in line 1, then that is the best to use, as it will allow a later selection to show you the
names of the fields. If you do not, then it merely numbers the fields and line 1 is like any other line.

Having selected the type of file, then you will see a Location bar, and clicking that will open the 
search dialog to find the file and Open it. You will then see all the records, and you can select which
ones you want to use with the checkboxes against each item. Hit OK to accept the selections.

To insert the appropriate text in the right places of the text, use the Insert Merge Field button. It 
will show a list of the fields and you can select to insert at the cursor position in the text. You can 
then add whatever fixed text as well as you create the contents of the text box.

If you find the text might not fit the box, then under the Style tab of the text pane, there is a 
checkbox to tell gLabels to shrink the text if necessary to fit.

More Text Editing
You can put as many other text boxes in the label as you like, so, for instance, you can add your 
own return address, and give it a different colour with the chevron next to the underlined T along 
the bottom of the window; or via the Style tab in the Text pane.

Inserting an image
One thing to note is that there is no transparency control in gLabels, and so every image should be 
prepared appropriately beforehand. If you want a pale background picture for some reason, then it 
should be created like that before inserting into the label or business card.
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Use the Image icon (or Object → Create → Image) and click about where you want the image. It 
will put a checkerboard pattern in place, and on the right will be pane for you to select the file to 
load with the image.

In the Size tab you can change the size of the image as you will. The padlock on the right here 
allows you to lock the ratio of the height to width so you can keep it properly proportioned.

If you right click in the main part of the window on the image, you will see a menu that will allow 
you to rotate the image, but only by multiples of 90 degrees.

Other features
There are also simple drawing tools for adding lines, rectangles and ellipses/circles.

The right click menu on a selected object also allows you to move the object to the back or front so 
it is either overlaid by or overlays other objects.

Printing
The print feature is quite flexible. Hitting the Print icon (or File → Print) will produce a dialog for 
printing.

The Labels tab is useful. If you have sheets of labels that have been partially used, then in this tab, 
you can state which label to start printing at. This will enable you to make best use of your 
stationery.

Blank lines

If a line is completely empty (that is not even a blank in it), then it will automatically be skipped 
and no blank line will appear in the label. But the line must be totally empty for this to happen.

Preparation of images using LibreOffice Draw
This section will describe some ways of using Draw to prepare pictures for insertion in various 
other applications, like gLabels. There are a surprising number of simple but effective modifications
you can make to a picture with this tool, such as cropping, stretching and fading in various ways.

After opening Draw for a new drawing, you may first wish to convert to landscape with either 
Format → Page Properties, or the image icon on the sidebar. If you do not see the side bar, then go 
to View menu and tick the Sidebar checkbox.

In fact, to make some things easier, ensure from the View menu you have these ticked: Status Bar, 
Rulers, and Sidebar. Also, from View → Toolbars, it is useful to have both Standard and Drawing 
ticked.

Now load the image with Insert → Image, or the icon on the standard toolbar.
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Adjust the image size

You must select the image by clicking it before any changes can be made.

The image may not be a suitable size to calculate convenient ratios, so adjust the size to something 
more appropriate. For example if part of the operation is to convert in some way an image with an 
aspect ratio of 4 x 3 to one of 16 x 10, then you might like to adjust the size so the long dimension 
is 16 cm long. Your can either drag it and adjust by eye, but more accurately by right clicking on the
image and selecting Position and Size to get a dialog.

Make sure that the Keep Ratio box is ticked, otherwise you will be stretching the image one way or
another.

Then set the width to what you want. You may also want to put the origin (top left by default) of the
image at a more suitable place as well.

Cropping

The next task may be to crop the image to the size you want. This is done by right clicking on the 
image and selecting Crop and the selection markers will change from green to red, and when you 
place the cursor over one of them it looks like a cutting square. You can now adjust with the cursor 
and watch the size as reported in the bottom information bar.

Now click anywhere else and the cropping will take place. The image will now be the size you 
want.

You should note that Draw seems to be able to crop to certain values, so the actual size as listed 
may vary slightly from the ideal you want. But you can get very close. When you are very close an 
adjustment of the size, not keeping the aspect ratio constant, will make it be exactly what you want, 
with minimal distortion.

Fading

To fade an image, for example to use as a faint background for  a business card, or similar, then the 
process is to overlay a rectangle and set the properties of the rectangle to be semi-transparent. The 
less the transparency the fainter the image will be. Depending on the picture, you may wish to 
experiment to see what a suitable value would be for your purposes.

Deselect the image first (use Escape or click elsewhere on the page). Now click on the rectangle on
the left sidebar and when the cursor is moved onto the canvas it will show a cross. You can then 
hold and drag a rectangle to the appropriate size. The default will put a solid colour and it will be 
totally non-transparent, so it will obscure the image. Now either by using the right side panel with 
Position and Size properties, or right-click and select Position and Size, set the X and Y 
coordinates the same as the image, and the size also the same. This ensures it is properly positioned 
exactly over the image.
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The next step should probably be to remove the line around the rectangle. Using either the Line 
properties in the sidepane or right-click and Line. In the sidepane the central button showing a line 
is the one to change. It should be set to None. (Of course if you want a frame, then set the width and
colour as you want.)

Next change the fill colour to white by using the Area properties, or right-click and Area. The Fill 
should be given as Colour, and hit the colour section to select white from the chart.

The transparency setting is available either in the sidepane or right-click and Area dialog. To see 
what sort of effect you want, select Transparency type as Solid (meaning even across the whole 
rectangle) and it defaults to 50% and you will see a fainter image of the picture you want. Adjust the
transparency to something that you might want for your purposes.

There are several different options for both the Fill colour and the transparency. These interact in 
some interesting and non-obvious ways. Experimentation for the intrepid is recommended to obtain 
unusual effects for your purposes.

In each of the sections of the Properties pane, there is a box top left which shows either a minus or 
plus sign. Clicking that will expand or shrink the selection.

Also in each section at top right is a box with three dots in it. Clicking that will open a much fuller 
dialog box where all the functions are available, and more than can be seen in the side pane.

Saving the result

You still have to get the image in a form that the other application can use. This is done in two 
stages, first group together the image and its overlying screen, and second to export it in a suitable 
format.

First deselect all items. Then using the cursor drag and draw a line clearly around both the image 
and its overlying screen. Green markers will then show where the boundaries are for the selection. 
Next use Modify → Group to make these into a group of items, and they will then be treated as a 
single item until Ungrouped.

With this group selected, use File → Export to bring up the dialog to choose a place.

Important: in this dialog, first tick the Selection checkbox at the bottom. This is important, 
otherwise it will export the whole page and will not be what you want. It is very easy to forget this
and should be the first thing to check if the results are not what you were expecting.

Then select the type of file from the drop-down on the right. I would recommend jpg, or tiff. Do 
not use svg – it will not handle images well, or even at all.

Then you can browse to a suitable place and save the file. Depending on the file type requested, you
may be shown another dialog to tailor the compression and/or quality of the result.
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